Start a new topic

PowerJobs: Automatic login

Add an option to automatically login when starting powerJobs/restarting the system like the Vault jobprocessor, so it isn't needed anymore to manually login into powerJobs.


22 people like this idea

Thomas


I tried a different approach - the default action on the dialog box is the "OK" button, so I rewrote the script to "press the Enter key"


That worked correctly for me.


To test if this approach works with your set up, run powerJobs, wait for the dialog to appear, and press the Enter key. If it logs in to powerJobs/JobProcessor this approach should work


To implement this, comment out the ControlClick line (; at the start, and add the Sleep & Send lines as shown below 

;ControlClick, OK, %loginTitle%, %loginText%
Sleep, 1000 ; in milliSeconds 1000 = 1 second
Send {Enter}
 

 You may or may not need the delay, and may need to change the time which is in milliSeconds. For my system it was not needed 


Then recompile (it will overwrite the previous version) & try again

Good luck!


Nick

Nick

Thank you so much for your help.
I tested your version with the Enter key.
The problem is probably an authority issue.

Calling the created StartPowerJobs.exe only works with "Run as administrator".
The registered user is a member of the local administrator group of the computer. I can't explain why this doesn't work directly.

I also tested your first version with "Run as administrator". Also this version would have worked.

I am now looking for a way to solve the permission issue.

Thomas


Translated with www.DeepL.com/Translator

 Thomas

 

If you want to force a AutoHotKey script to run as Administrator, you should add this code to the top of the script, and recompile


Note that it only works with compiled scripts


Hopefully it will help you

if not A_IsAdmin
{
   Run *RunAs "%A_ScriptFullPath%"  ; Requires v1.0.92.01+
   ExitApp
}

 Nick


1 person likes this

Nick,

Thank you very much for this solution. AutoHotKey now works as desired.
Thanks for your support.

Thomas

Based on the testing that Thomas has done, this would appear to be a good, general-purpose solution, using AutoHotKey - https://www.autohotkey.com/


  • Download the latest installer & install AutoHotkey
  • Download the attached script
  • Right-click -> Compile Script
  • This will build StartPowerJobsAsAdmin.exe
  • You can then move it into your startup folder, or use another method to automatically run it


Note that you need to run powerJobs manually and login successfully with the correct user/password before this will work, 


Also, check Brendan's post earlier if you want to change any of the login settings - his example changes the server


Nick

ahk
(449 Bytes)

1 person likes this

Can we please have this feature in the coolOrange powerJobs software as soon as possible, so we do not have to configure so many custom solutions to this simple issue?

Hope this option will be available in the next version

I wanted to let you know that the feature request has been planned and it will soon be available in the next powerJobs Processor version :)


The login credentials must then only be specified during the first launch, just like with the Autodesk Job Processor.

Even powerJobs Processor will remember them afterwards and will no longer prompt for login credentials.



I read some of the approaches for automatically starting the powerJobs.exe on Windows startup and I assume that they will still be relevant to you, because they allow a similar behavior as with the Start on Windows Logon option of Job Processor.


When updating these scripts, I would rather advise against the mentioned solutions of starting the powerJobs.exe with "Run as Administrator" because some customers report problems with Inventor when launching the Job Processor with elevated priviledges.


1 person likes this

This feature was implemented in powerJobs Processor 22.0.3.

The new powerJobs Processor version can be downloaded from the coolOrange Download Zone.


Kind regards,

Manuel Cassan

Good news. I download it right now.

Thank you very much for the warning.


Regards,

Jordi Fabregat senior

Login or Signup to post a comment