Start a new topic

Do not Log "Property is up to date"

Is it possible to exclude the INFO "Property [internal prop name] is up to date" when updating items? For reasons out of my influence, this is happening A LOT in one of my jobs. It clutters the log file and the visible log viewer thing included in powerJobs stops to show anything after a certain number of lines.


I looked at the log4net config file for powerJobs but if there is such an option, it is not obvious.


Thank you!

1 Comment

Hello Tim,

You could set the log level higher so INFO logs are not logged anymore. Please refer to this article for a guide on how to change the log level. On this page you can find information about the different logging levels. Alternatively  you can try to use the following in your log4net configuration file:

<filter type="log4net.Filter.StringMatchFilter">
     <stringToMatch value="My Exclude String" />   
     <acceptOnMatch value="false" /> 
</filter>

This should be inserted in the FileAppender.


Kind regards,

Manuel Cassan

Login or Signup to post a comment