Start a new topic

Vault2FLC: Projects do not work anymore

Hi guys,


Until a couple of days ago the project creation from FLC to Vault was working fine. I was able to create a project in FLC and soon later a folder structure would get created in Vault.


As of today, this functionality does not work.


I noticed that FLC was undated on August 27th. Is this issue regarding the new update in FLC?


https://help.autodesk.com/view/PLM/ENU/?guid=PLM_360_WhatIsNew_What_s_New_html


I would really appreciate your help!


Hello Shaya,

Can you please describe the issue you are experiencing in more detail?


Kind regards,

Manuel Cassan

Hi Manuel,


I was able to fix the issue and thanks for getting back to me.


I have a questions for you:


As you can see in the image below, I have setup the Schedule Job Interval to 1min. My Vault Job Processor is set to 20sec. However, it takes more than 5min for the project sync to happen. It seems that even though I have selected 1min forĀ Schedule Job Interval, in the back end it's waiting much longer.

image


Hello Shaya,

Do you mean the period in which the jobprocessor checks for new jobs is set to 20 seconds? If so please have a look at this article on the Autodesk Knowledge Network. A value below one minute will impact performance.

Please check if the service "Autodesk Data Management Job Dispatch" is running on your jobserver machine. This service is needed for scheduled jobs.


Kind regards,

Manuel Cassan

Hi Manuel,


I don't think the issue is related to the server performance. All the functionalities of the Vault2FLC tool work fine. Even the Project feature of the Vault2FLC tool works. The issue is how often the Project feature runs. As you saw in the image I have, the scheduled job interval is set to 1min. However, this job runs every 10min. It seems that even though it is set to 1min in user interface, the Vault2FLC program doesn't consider the 1min that I selected. It takes it's value from somewhere else.


I hope this explain the situation better.


Thanks,

Hello Shaya,

The scheduled jobs interval ist using the Vault API for this so this depends on the Vault API. In the documentation i found no information that there would be a minimum value or similar.


Kind regards,

Manuel Cassan

Hello Shaya,

After doing some more testing we came across following issue:

The interval is only updated after disabling the Project Synchronization and enabling it again in the vaultFLC options.


Kind regards,

Manuel Cassan

Thanks, I will try out your suggestion.

Login or Signup to post a comment