Start a new topic

Speed of job processing decrease

Hello,


I have a Problem with the speed of my powerjobs:

I have a list of  100 Jobs to do. At the beginning the Jobs run very quickly. But the speed gets lower and lower with the time. So after maybe 30 minutes the same Job needs more than twice of time!! If I stop an restart powerjobs the speed is again very fast.

What can be a reason for this? And is their a way to clean up the powerjob?


Thanks a lot for helping.


Regarding

Martin


Hello Martin,

Which powerJobs and Vault version are you using?


Kind regards,

Manuel Cassan

Hi Manuel,


first thank you for helping us!


Our  Vault Clients Versions are 2017 (Build 22.0.56.0). Also Job Processor.

The Vault Server Version is 2018. (Build 23.0.76.0)

Powerjobs 18.0.


Kind regards,

Martin

Hello Martin,

Did you notice an increased memory usage when powerJobs gets slower?

In that case you could try to update powerJobs to version v19. In version 19.0.7 a memory problem was fixed.

Which v18 version are you using? You can find the exact version in the Apps and Features.


Kind regards,

Manuel Cassan


Manuel,


I using the Version 18.0.17.19178 of powerjob.


It is possible to run powerjobs Version 19 with Vault 2017?

Thanks for your Information. If the different versions are not a Problem I will try your idea and come back with a Feedback!


Thanks!

Martin

Hello Martin,

Do you mean 18.0.12?

powerJobs v19 is still compatible with Vault 2017.

Please have a look at the breaking changes in version 19.0.7.

we can update the jobs for you so that they will work with powerJobs v19.


Kind regards,

Manuel Cassan


1 person likes this

Manuel,


Yes, It was 18.0.12.


I installed the new Version 19.0.7. And now the first tests showed an improvement of speed. This Looks fine!


My Jobs works correctly, but I get an error message before every Job: "Error occured when Setting execution policy!" Please see the file I attached!


What is the reason for this error and what can I do?

What did you mean with update my Jobs?


Thanks a lot for helping. The speed increase will helping us so much.

Martin


Hello Martin,

At the start of every job powerJobs sets the Execution Policy. If this is controlled by Group policies or similar you get this error. Can you please check with your IT department if that is the case?

By updating jobs i meant that the powerShell script could be updated as there were breaking changes in version v19. A deprecated module was added to still be able to use e.g. Add-Log so you could also leave them as they are.


Kind regards,

Manuel Cassan

Hi Manuel,

thanks for your feedback. Our Policy is controlled by a global Group policy.

So I did not have a possibility to change. Do you have an idea what I can do? Is there a possibility to keep down the error in the log file?


Thanks,

Martin



Hello Martin,

If i understood you correctly, you want to exclude this specific message from the logfile, is that correct?


Kind regards,

Manuel Cassan

Yes, this is correct.


Thanks,

Martin

Hello Martin,

To exclude a specific message from the logfile you can use the following:

<filter type="log4net.Filter.StringMatchFilter">     
     <stringToMatch value="My Exclude String" />        
     <acceptOnMatch value="false" /> 
</filter>
This should be inserted in the FileAppender to exclude it from the logfile.

Kind regards,
Manuel Cassan


Login or Signup to post a comment