Start a new topic

Attachments are not added to FLC items

During Items & BOMs publish, I noticed couple things are not working:

1. Some of the thumbnail images are not coming across

2. Attachments are not added to the items with following error in the job queue:

[ ERROR] - Error while trying to upload attachment 'Inlet Ring.ipt.dwf': Could not find file 'C:\Vault 2020\Designs\Inventor Sample Data\Boxermotor\Parts\Inlet Ring.ipt.dwf'., Error while trying to upload attachment 'Inlet Ring.dwg.dwf': Could not find file 'C:\Vault 2020\Designs\Inventor Sample Data\Boxermotor\Drawings\Inlet Ring.dwg.dwf'.

It seems like coolOrange is looking locally on my machine for the DWFs.


Hello Vahid,

The issue that thumbnails are not getting sent correctly to Fusion Lifecycle is known. This should only be an issue when creating a new item. When updating an existing item the thumbnail should be displayed correctly.

Regarding the issue with attachments, could you please send me the full logfile from "C:\Users\{USER}\AppData\Local\coolOrange\vaultFLC\Logs"?


Kind regards,

Manuel Cassan


Here you are.

Regards,

Tony Zohrehvandi

Autodesk

log
(4.3 MB)

Hello Vahid,

Thank you for the logfile. I will try to reproduce this issue and get back to you as soon as possible.


Kind regards,

Manuel Cassan

Hello Vahid,

Next week a version will be released where the attachments issue is fixed. I will post a message here when the version is released.


Kind regards,

Manuel Cassan

Hello Vahid,

vaultFLC 20.0.7 was just released on the coolOrange download zone. In this version the issue with uploading attachments is fixed and some other improvements were made. You can read the change logs on this page.


Kind regards,

Manuel Cassan

Hi Manuel,

I just tested the new release and the thumbnails are working now but I still have the issue if DWF files not coming across with the following error in the job queue:


[ ERROR] - Error while trying to upload attachment 'Combustion Chamber_w.ipt.dwf': Could not find file 'C:\Vault 2020\Designs\Inventor Sample Data\Boxermotor\Parts\Combustion Chamber_w.ipt.dwf'., Error while trying to upload attachment 'Combustion Chamber_w.dwg.dwf': Could not find file 'C:\Vault 2020\Designs\Inventor Sample Data\Boxermotor\Drawings\Combustion Chamber_w.dwg.dwf'.


I checked and the DWF exist in Vault. I have also uploaded the log file.

log
(46.9 KB)

Hi Manuel,

This could be a Vault issue, I tested it with an older version of CO and the same error occurs. Vault version is: 25.2.83.0

Hello Vahid,

From the logfile it looks like version 20.0.1 is still used. Have you upgraded to version 20.0.7? In this version the attachments issue is fixed. The thumbnail issue is currently being worked on by our development team. Next week that issue should also be fixed.


Kind regards,

Manuel Cassan

Hi Manuel, I just uninstalled and reinstalled and it is working now. See the log file.

log
(460 Bytes)

Hi Manuel, 

It seems like it is now working intermittently. I tested another assembly and it failed on attachments. Log file is attached.


log

Hi Manuel,

I think this could be a Vault issue. Let me test a few things and let you know what is happening. Stand by, please.

Regards,

Tony

Hello Vahid,

It looks like the files get downloaded to the working folder when the job is executed.


Kind regards,

Manuel Cassan

Hi Manuel,

I just finished testing this and it seems like the latest build of Vault 2020 is the problem. The lates coolOrange connector works fine with Vault Build 25.0.66.0


Regards,

Tony

Hi Manuel,

Below is the result of my testing for multiple configurations:


Vault Version CO Version Issue    
Vault Pro 2020, Build 25.0.66.0 cO_vaultFLC20.0_Vault2020, Build 20.0.1.24252 No issue, it is a working combination
Vault Pro 2020, Build 25.0.66.0 cO_vaultFLC20.0_Vault2020, Build 20.0.5.24700 Issues with thumbnail, attachment and assemblies
Vault Pro 2020, Build 25.0.66.0 cO_vaultFLC20.0_Vault2020, Build 20.0.7.24838 No issue, it is a working combination
Vault Pro 2020, Build 25.2.83.0 cO_vaultFLC20.0_Vault2020, Build 20.0.1.24252 Issues with thumbnail, attachment and assemblies
Vault Pro 2020, Build 25.2.83.0 cO_vaultFLC20.0_Vault2020, Build 20.0.5.24700 Issues with thumbnail, attachment and assemblies
Vault Pro 2020, Build 25.2.83.0 cO_vaultFLC20.0_Vault2020, Build 20.0.7.24838 Issues with thumbnail, attachment and assemblies
Login or Signup to post a comment