Issue

When using powerGate 18.1.3 (or later) in a powerJobs job, the job fails when calling:

Connect-ERP -Service ...

Following error message will display:


The log file contains following entries:

[ ERROR] - An exception was thrown while invoking the constructor 'Void .ctor()' on type 'ErpClient'. —> Die Datei oder Assembly "licensing.Core, Version=16.0.174.19450, Culture=neutral, PublicKeyToken=435ef1f2973df9b6" oder eine Abhängigkeit davon wurde nicht gefunden.
    Eine Assembly mit starkem Namen ist erforderlich. (Ausnahme von HRESULT: 0x80131044) (See inner exception for details.)


Cause

PowerGate delivers the licensing.Core component that has strongname, meanwhile powerJobs does not use a strongname version of the assembly.

Because powerGate gets imported/used in a powerJobs runspace, the required strongname version is not found, since the version without the strongname is available.


Solution

The issue got fixed in powerJobs 18.0.12 which now supports the strongname version of the assembly that gets installed to the GAC.

Therefore we recommend to update to the latest powerJobs version in order to have this issue fixed!