Issue

When using DTU following error could appear in the terminal:

Vaultbcp [Version 21.0.59.0]
Unsupported ADMS product version: 21.1.4.0


Cause

One cause could be that a Vault Server update increased the ADMS version while the version in Vaultbcp.exe.config remained the same.


Solution

Edit the Vaultbcp.exe.config and change the version to the appropriate AMDS version.

<add key="AdmsVersion" value="21.1.4.0" />

This solution only works when the Major ADMS version is the same as the configured one.