Issue

An activated license is updated (e.g. the license duration is extended) but the product's splashscreen and the license information tool still display the old license data.


Cause

This issue can arise because the products only get the license from the license server the first time they are started and then create a local copy of the license for further uses. An exception to this are Token licenses, they are retrieved every time tokens are consumed.


Solution

Wait until the license expires or in case of a token license until additional tokens are consumed and the product should automatically retrieve the latest version of the license.


Alternatively you can force a refresh of the license by deleting the locally cached license file and starting the product again.

The cached license file is usually stored in the product's localAppData directory: 

'%localappdata%\coolOrange\<productName>'. 

This will force the product to retrieve the license from the license server with the latest license details.


Remarks

  • When a license is used offline, the activation file needs to be replace by a newly generated one.
  • Deleting the cached token license file will cause additional token consumption.


See also