Trouble shooting

Open-VaultConnection returns error 404
Issue When the Open-VaultConnection commandlet is used it returns an 404 error. This is only the case when attempting to connect to an incompatible Vault S...
Thu, 23 May, 2019 at 1:23 PM
How to export BOMs in case of problems
Issue: The powerVault commandlet 'Get-VaultFileBom' is crashing on your machine or not behaving correctly and our product support asked you to ex...
Mon, 4 Oct, 2021 at 5:41 PM
When updating a Vault property of type Date, it does not update correctly
Issue When trying to change a property of type Date of a Vault File using the Update-VaultFile cmdlet, it clears the property or doesn’t correctly Solu...
Mon, 4 Oct, 2021 at 5:42 PM
Failed to find 'Autodesk.Connectivity.WebServices' assembly
Issue The commandlet Import-Module powerVault fails with following exception: Could not load file or assembly 'Autodesk.Connectivity.WebServices, C...
Mon, 4 Oct, 2021 at 5:42 PM
How to remove a lifecycle definition from a file
Issue Removing a lifecycle definition from a file  using powerShell, this is not possible using the Update-VaultFile Commandlet Solution To achieve th...
Mon, 4 Oct, 2021 at 5:44 PM
Copy design file does not reference the copied dependency
Issue Associations of a file in Vault have been altered with the cmdlet Update-VaultFile. The file and it's dependencies are copied via "Copy-Des...
Mon, 4 Oct, 2021 at 5:45 PM
powerVault runs in an endless loop
Issue When using cmdlets from powerVault e.g. Add-VaultFile the function seems to run into an endless loop. If you are using e.g. powerShell.exe or another...
Thu, 23 May, 2019 at 1:13 PM
BOM quantity is wrong
Issue The quantity of a bomrow which is retrieved by Get-VaultFile is wrong. Cause The assembly was checked in with Autoloader. Autoloader has several...
Mon, 4 Oct, 2021 at 5:48 PM
Get-VaultFileBom returns 1013 exception
Issue When using Get-VaultFileBom the cmdlet crashes with a 1013 exception: Solution Check out the file in Inventor and check it back in. This shoul...
Mon, 4 Oct, 2021 at 5:48 PM
Get-VaultFileBom -Recursive is not working
Issue Get-VaultFileBom returns only the first level of children even though the -Recursive parameter is set. Cause The -Recursive parameter is availab...
Mon, 4 Oct, 2021 at 5:49 PM