License information is not updated

An already registered Stand-Alone License is renewed but the product's License Information dialog still displays the old license information.

Issue

When using Licensing v18 or newer an already registered Stand-Alone License is renewed but the product's License Information dialog still displays the old license information.

Cause

The issue can arise when registering a Stand-Alone license using a Serial Number. In this case the products only retrieve the license information from the License Server the first time when they are started and create a local copy of the license for further use.

Solution

There are multiple solutions to this issue. The recommended solution is to update the product version as described in "Solution 1".

Solution 1

Upgrade your products to at least the following versions that are using Licensing v18.1.22 or later:

It is only necessary to update one product in order to update the licensing version. All other products will use the updated licensing.

Solution 2

Wait until the Stand-Alone license has expired. The License of the product will automatically be updated either when using it or when opening the License Information Dialog.

Solution 3

Alternatively you can force a refresh of the license by deleting the locally stored license file and starting the product again.

The stored license file is usually stored in the product's localAppData directory:

  1. Open the folder "%localappdata%\coolOrange\<Product Name>"
  2. Delete the license file
  3. Restart the product

This will force the product to retrieve the latest license information from the License Server.

Remarks

In Offline Activation scenarios the License Information dialog displays the up-to-date license information after replacing the registered Activation File with a newly generated one.

See also