powerGateServer requests fail with "The maximum message size quota for incoming messages has been exceeded"

Issue

When sending a request to powerGateServer it fails with the following message:

Internal Server Error! The maximum message size quota for incoming messages (65536) has been exceeded. To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element.

Cause

This issue happens when the size of the message exceeds the maximum size for incoming messages.

Solution

The size for incoming messages can be increased by adapting the binding element in your app.config file in your Plugin directory. Normally the powerGateServer plugins are located in "C:\ProgramData\coolOrange\powerGateServer\Plugins".

to increase the size for incoming messages you can use the following:

<bindings>
<basicHttpBinding>
<binding name="Binding1"
maxReceivedMessageSize = "1000000">
<security mode="None" />
</binding>
</basicHttpBinding>
</bindings>

See Also