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Starting powerGateServer service results in error 1053

Description

When powerGateServer runs on a system without internet access the powerGateService takes a long time to start and then fails with 

Error 1053: The service did not respond to the start or control request in a timely fashion

When running the powerGateServer console it takes a long time to start, but then works normally.

When the service is started it attempts to connect to "http://crt.sectigo.com"

Cause

This can happen if the machine was without internet access long enough for the powerGateServer certificate to expire. 

Solution

Check the powerGateServer certificate validity

* Right click "C:\Program Files\coolOrange\powerGateServer\powerGateServer.exe"

* Open Properties

* Select "Digital Signatures" tab and for "COOLORANGE" certificate open "Details"

* In "General" tab select "View Certificate"

* Check the "Valid to" date

If the certificate is outdated your IT needs to update the trusted root certificates. It is necessary to trust every certificate in the chain

See Also

* Sectigo-Intermediate-Certificates(Sectigo)