Uninstalling product not possible when Vault is not installed

Issue

When trying to uninstall a Vault dependent product, the correct Vault version needs to be installed.

Cause

The coolOrange setups check if the correct Vault version is installed

Solution

If Vault was already uninstalled and you are trying to uninstall a coolOrange product you can do the following:

Solution 1

Install the Vault Client again

Solution 2

You can manually add the registry key that is used by coolOrange products to check if the Vault client is installed and uninstall the product:

  1. Open the Windows Registry Editor
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\PLM\Autodesk Vault Professional <VERSION>\Common
  3. Right click on the "Common" folder and click on "New" and then "String Value"
  4. Name it "InstallLocation".
  5. Double click the newly added value and set the "Value data" to "C:\Program Files\Autodesk\Vault Client <VERSION>\"
  6. Uninstall the coolOrange product
  7. Delete the value from the registry by right clicking on it and selecting "Delete"