When running powerGateServer as a service requests fail with "License is expired", even though the license is activated
Description
When running powerGateServer as a service no request works and and error message like
"Internal Server Error! License is expired: please activate powerGateServer now"
is returned.
When looking into the license manager, it shows the license is activated.
Cause
This happens when the service runs under a service user account. Our licensing writes and reads files from the user directory, which might not be possible for service accounts on every system.
Solution
* Use the offline activation to activate powerGateServer
* Use a separate windows user to activate powerGateServer and run the service under that user